I suggest you ...

Office files OneDrive sync issues since latest update of Windows

Since the last Windows update, I have seen inconsistent OneDrive behavior with Office files:
- Even though "Use Office 2016 to sync office files" is turned off, Office still tries to directly upload files to OneDrive when closing a file
- Much frequent occurrences of the "You now have two copies of a file" when saving office files, which force to waste time in cleaning up the duplicated files.

For the first issue, I temporarily changed the "Use Office 2016 to sync office files" to on, then back to off. That seemed to have stopped the upload to OneDrive while closing Office file.
But that did not resolve the second issue.

I have run into the same issue on multiple computers. That issue did not occur until the fall update.

139 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Yves shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    25 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • John Krzeszewski commented  ·   ·  Flag as inappropriate

        I also have been having this issue and it is SEVERLY affecting my productivity. Office applications constantly "freeze" for MINUTES at a time (not a few seconds), even though I have the "Use Office 2016 to sync office files" turned off. HELP!

      • DavidT commented  ·   ·  Flag as inappropriate

        Jeff

        Thanks for the further explanation. I have:

        Office 365 Version 1802 (Build 9029.2054) Monthly Channel (Targeted) and
        OneDrive 2018 (Build 17.005.0107.0008)

        My apologies - I didn't mention my settings on the OneDrive Auto-save Tab. I have all three locations set to 'This PC only'

        On the OneDrive Office Tab I have removed the tick in the box for 'Use Office 2016 to sync Office files that I open.

        I concur with your description of scenarios 1 & 2, but the problem is that all new files (whether brand new or a file created by Save As from an existing file) are created with the wretched AutoSave switched on. True, I can then switch it off but, by then, I have two files in my OneDrive folder, the original and the conflict duplicate appended with my Computer name. It is this constant creation of duplicate files that is driving us all nuts.

        There is a workaround, but it's not a viable option in a busy office. Create the new file, turn AutoSave off, close the file before writing anything into it (that is the important bit) and then watch the OneDrive Cloud icon until it stops syncing. You can then re-open the file and it will say 'Saved to this PC' at the top and behave like Dropbox.

        The problem of ending up with conflict copies happens when you follow the normal business practice of creating a new file and then starting working on it straight away. I'm not entirely sure of the sequence but it appears to be:

        1. You click 'Save' or 'Save As' to create a new file.
        2. Word uploads the new file direct to the Cloud.
        3. OneDrive syncs (downloads) the initial version of the file to your hard drive but keeps the sync engine running. (the circles remain on the icon showing it is syncing)
        4. Meanwhile, you work on your file and, when you have finished, you close it.
        5. Word appears to save this direct to your hard drive and upload it direct to the Cloud.
        7. OneDrive syncs (downloads) the final version to your hard drive and (this is the crazy bit), decides there is a conflict and creates a conflict copy even though both copies turn out to be identical.

        I am quite certain I haven't got this sequence right in terms of what is saved where and when, but the result is beyond question: if I work on a newly-created file I will get an unwanted conflict duplicate every time.

        DavidT

      • Jeff Pollard commented  ·   ·  Flag as inappropriate

        Hi David

        A couple of things to be aware of:

        There are 2 separate functions called Auto-Save. They are completely unrelated, but confusingly MS decided to reuse the same name twice:

        1.) 'OneDrive Auto-Save'
        This setting is on the Auto-Save tab in the OneDrive client settings. By default, this setting grants the OneDrive client permission to continously monitor the 'Desktop', 'Documents', and 'Pictures' folders on your local machine, and automatically and silently syncs them to the cloud. You can disable this bevaiour by selecting the 'This PC Only' setting. This function has no bearing on the Office & OneDrive sync issues.
        https://support.office.com/en-us/article/Files-save-to-OneDrive-by-default-in-Windows-10-33da0077-770c-4bda-b61e-8c8e8ca70ac7

        2.) 'Office AutoSave'
        This is a new feature which is built into the most recent versions of Office 365. It means that whenever you access a file in your local OneDrive folder, Office will force that file operation to be performed directly in the cloud, rather than locally. 'Office AutoSave' is gloablly enabled by default, and can only be switched off on a per-file basis.
        https://support.office.com/en-us/article/what-is-autosave-6d6bd723-ebfd-4e40-b5f6-ae6e8088f7a5

        Assuming you have the latest version of Office 365 which includes the AutoSave feature, there are 2 possible configurations:

        Configuration 1:
        If a file has AutoSave set to ON, then the fact that we have unchecked the "Use Office 2016 to sync Office files that I open" setting in the OneDrive client is ignored, and Office will force all OneDrive file operations to happen directly in the cloud, rather than locally, whether we like it or not.

        Configuration 2:
        If a file has AutoSave set to OFF, then the fact that we have unchecked the "Use Office 2016 to sync Office files that I open" setting in the OneDrive client IS respected: i.e. Office will not force file operations to happen directly in the cloud, and the OneDrive client will continue to function as it did before (i.e. like Dropbox).

        An issue occurs if you have the latest version of the OneDrive client coupled with a non-current version of Office 365 (i.e. version 1708 from the Semi-Annual Office update channel). In this scenario, the latest version of the OneDrive client ignores the "Use Office 2016 to sync Office files that I open" setting and forces all Office file operations to happen directly in the cloud in all cases PLUS the non-current version of Office 365 does not give you the option to counteract this enforced behaviour by switching off AutoSave. So it's not OneDrive that you need to update, it's Office 365, and the registry hack I provided below just allows you to switch from the Semi-Annual Office update channel to the Monthly Office update channel.

        Even if you do have the latest version of Office 365 and use the AutoSave Off setting (to bring back the Dropbox-like OneDrive behaviour), this only works on a per-file basis. To trick Office and OneDrive into behaving like Dropbox all the time, then your only real option is to create a Virtual Drive for your OneDrive folder, as I described below.

        Hope that makes things clearer.

        Needless to say, I urge everyone to continue to lobby MS to disable AutoSave gloablly and respect the "Use Office 2016 to sync Office files that I open" opt-out setting, by default. AutoSave should always have been an opt-in feature, not a coersion.

        Cheers
        Jeff

      • DavidT commented  ·   ·  Flag as inappropriate

        Sincere thanks to Jeff Pollard for his detailed explanation of what is happening.

        Jeff: I already have the latest OneDrive version on all our user's machines and I don't feel inclined to do a Registry hack on every one of them.

        Yes - we can turn off AutoSave on a per file basis, but only AFTER we have ended up with an unwanted duplicate file. We need a mechanism to stop these duplicated files being created in the first place.

        I'm still puzzled over what effect the tick has in the box labelled "Use Office 2016 to sync Office files that I open." on the Office tab of OneDrive settings. Does the latest edition of Word 2016 include its own sync engine entirely separate to OneDrive?

        For the those of us who do not wish to be able to work concurrently on a file with a co-worker (I suspect that's the overwhelming majority of users) and just want OneDrive to work as it always did, are we best to have a tick in this box or not?

      • DavidT commented  ·   ·  Flag as inappropriate

        This is my experience of the issue:

        Since last November I have been having real problems saving Office files to my OneDrive Folder or one of my Company’s SharePoint Folders. (In all cases the Folders are synced to my PC)

        Whenever I save a new Office file either to my OneDrive folder (Personal) or to one of my Company’s SharePoint folders I end up with two copies instead of one. This is the sequence:

        Open a New File ==> Save As to my OneDrive Folder on my PC. The file very slowly saves direct to the Cloud and at the top of Word it says, ‘Saved to OneDrive’. If I then make changes to the document and close it I end up with two copies in my OneDrive Folder on my PC - the second one being a duplicate with my computer name appended. This is the behaviour when there is conflict between versions edited by different users, but I am the only user. This is not expected behaviour and it is making OneDrive and SharePoint unusable.

        I have done some experiments with saving in different locations:
        1. Open a New File ==> Save As to my Desktop. The file saves instantly and at the top of Word it says ‘Saved to this PC’. This is expected behaviour.

        2. Open a New File ==> Save As to my Dropbox Folder on my PC. The file saves instantly to the Dropbox folder on my PC and at the top of Word it says, ‘Saved to this PC’. This is expected behaviour. After the file has been saved to my Dropbox folder on my PC, the Dropbox sync engine detects the new file and uploads it to the Cloud in the background. This is expected behaviour, and this is how OneDrive used to work. Each time I re-save my file Word updates the file in my Dropbox Folder on my PC. The Dropbox sync engine then detects the change and uploads the changes to the Cloud in the background. Once again, this is expected behaviour, and this is how OneDrive used to work. At no time does Word communicate directly with the Cloud. Word saves to the Dropbox Folder on my hard drive and that is all it does. The Dropbox sync engine continually scans the Dropbox Folder on my hard drive and it uploads new files and changes to the cloud as and when necessary. OneDrive used to work like this too. It changed sometime last Autumn, and I need to be able to make it work like this again.

        3. As 2 but Save As to my Google Drive Folder on my PC. This produces exactly the same results as with Dropbox - everything works correctly.

        These are the Options I have set:

        In my OneDrive Options:
        AutoSave Tab: All set to This PC Only.
        Office Tab: Tick removed from ‘Use Office 2016 to sync Office files that I open."

        In my Word Options:
        Save Tab: ‘Save to Computer by default’ is ticked.

      • Jeff Pollard commented  ·   ·  Flag as inappropriate

        See my previous posting (immediately below this one) for an explanation of the issue. To remedy the situation, I can offer 2 optional workarounds:

        1.) Force an Office 365 update.
        These steps will force your Office 365 to update itself to the latest version from the Monthly update channel, after which you can simply disable AutoSave on a per-file basis:

        Open a command prompt with administrator privileges and execute the following commands:
        - reg add HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\ClickToRun\Configuration /v CDNBaseUrl /t REG_SZ /d "http://officecdn.microsoft.com/pr/492350f6-3a01-4f97-b9c0-c7c6ddf67d60" /f
        - reg delete HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\ClickToRun\Configuration /v UpdateUrl /f
        - reg delete HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\ClickToRun\Configuration /v UpdateToVersion /f
        - reg delete HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\ClickToRun\Updates /v UpdateToVersion /f
        - reg delete HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Office\16.0\Common\OfficeUpdate\ /f
        - "%CommonProgramFiles%\microsoft shared\ClickToRun\OfficeC2RClient.exe" /update user

        2.) Create an intermediate virtual network drive.
        Regardless of which Office version you're on, this trick creates a local virtual network drive which points to the local instance of your OneDrive folder. When you access an Office file from this virtual drive, it fools Office into thinking it's accessing a normal (non-OneDrive) folder, and so it will just open and save the file locally rather than enforcing any online syncing. However, the OneDrive client will continue to perform online syncing in the background as normal. The virtual drive is persistent, i.e. it survives reboots. Create the virtual drive as follows:

        Open a command prompt (without administrator privileges) and execute the following command, substituting your [Desired Virtual Drive Letter], [Current OneDrive Drive Letter], and [Current OneDrive Path] as appropriate (without the square brackets):
        - net use [Desired Virtual Drive Letter]: "\\localhost\[OneDrive Drive Letter]$\[OneDrive Path]" /persistent:yes
        For example: net use P: "\\localhost\C$\Users\MyUserName\OneDrive" /persistent:yes
        To get rid of the Virtual Drive, you can just right click it in Windows Explorer and select Disconnect.

        Cheers
        Jeff

      • Jeff Pollard commented  ·   ·  Flag as inappropriate

        I don't hold out much hope for a fix for this issue, as I believe it is a feature not a bug. I suspect that it is related to the new so-called 'AutoSave' feature which is built into the most recent versions of Office 365. AutoSave enforces precisely the same behaviour we are now experiencing (Case 2 in my earlier posting, below), whenever an Office 365 application performs any file operation to or from a OneDrive folder (either the local or online instance):
        - Within the Office application, the user must be signed-in (with their OneDrive folder credentials).
        - All file operations are performed directly to or from the online OneDrive folder instance (via the internet).
        - Online file changes are then synced back to the local OneDrive folder instance.

        In addition, AutoSave continuously monitors user activity within the Office application (e.g. text entry, formatting, etc) and immediately saves an updated version of the file directly to the online OneDrive folder instance (via the internet) as soon as any such activity is detected.

        AutoSave cannot be globally disabled. You may be asking yourself why such a privacy-invasive feature cannot be globally disabled. I suppose that depends on your point of view. An optimist might say: "This AutoSave feature is so awesome, MS figured no one could ever want to disable it", whereas a cynic might say: "AutoSave provides MS with real-time, detailed usage monitoring tied to a known user account, and usage data is the new oil". You can join the debate here: https://office365.uservoice.com/forums/264636-general/suggestions/19082773-disable-the-new-autosave-by-default-as-it-can-lea

        In light of the above, our quest for a fix to this current issue is bound to be short-lived. MS is clearly shifting Office towards the 'Google Docs' business model, and that change is coming down the road whether we like it or not.

        The good news is: AutoSave CAN be deactivated on a per-file basis, and I can confirm that once it has been disabled for a particular file, then all Office applications once again respect the opt-out setting in the 'Use Office 2016 to sync Office files that I open' checkbox for that file, and it is possible to open and save that file directly to or from the local OneDrive instance. OneDrive then syncs the file in the background, just like it used to.

        At the time of posting, AutoSave is only available to Office 365 users on the Monthly update channel (current Office version = 1801). It is not available for users on the Semi-Annual update channel (current Office version = 1708). You can check which update channel you are on by looking in the Product Information section of the Account page.

        I suspect that the reason some of us are seeing strange behaviour is because we are stuck on the Semi-Annual update channel, in a scenario whereby the latest version of OneDrive (or FileCoAuth.exe to be exact) is enforcing online-only file operations, and yet our current version of Office 365 (1708) does not give us the option to disable this behaviour per file.

        I can offer 2 optional workarounds, see my following posting (above).

        Cheers
        Jeff

      • Steve commented  ·   ·  Flag as inappropriate

        Microsoft, Please fix this!! So aggravating. Plus, when saving Office to my SSD drive, it takes 5 seconds or so instead of a fraction of a second.

      • Anonymous commented  ·   ·  Flag as inappropriate

        Many of us have work protocols that require us to "up-rev" a document every time we edit it. That way, we have an historical record of changes. File V1, File V2, and so on. "Auto-Save" renders this impossible. I'm sure it's useful for some people, but for those for whom it is NOT, we should have the ability to TURN IT OFF in all applications.

      • Chris Beaufait commented  ·   ·  Flag as inappropriate

        This needs to be fixed. This "Auto-save" and Office integration into OneDrive is a complete mess. Make it simple, eliminate it or allow the option to disable the Office Upload Center.

        Unbelievable how much of a mess this has become.

      • Bill commented  ·   ·  Flag as inappropriate

        This needs to be fixed. I work on my files alone and have no need to collaborate. This feature is making me have to constantly delete "second copies" of files.

        In excel I constantly have to name my file a different name to save or I just get errors that the destination is not available.

        I also frequently need to open files and make changes to see different outcome WITHOUT SAVING THE CHANGES!!! If I forget to turn off auto-save on a file and do this, I'm screwed if I don't have a clean backup file to restore.

        Microsoft, make the auto save feature an option, not a forced default. Did you know Google Drive now offers collaboration on office files...maybe I don't need a personal subscription to 356 if work already has one. I can just use their subscription and throw my $ at Google for personal space if you're going to basically punish me for using Onedrive as a work storage space.

      • Michal commented  ·   ·  Flag as inappropriate

        Same issue here with every single user.
        Please, make "Use Office 2016 to sync office files" switch to work properly as it was in previous versions. Current behavior is unacceptable and our users already started to leave OneDrive storage completely, cause they consider this tool as waste of their time and useless for efficient work at the moment!

      • Mark Norman commented  ·   ·  Flag as inappropriate

        Hi

        I agree with the concerns expressed in the feed. File duplication and integration with office is painful, time wasting and annoying.
        Please rethink you strategy.
        In general I believe most users want to be able to:
        1) edit with office their local files
        2) when complete, have their local files replicated and updated on the one-drive cloud
        3) not have duplicate issues
        4) generally not have office downloading files from the cloud for editing

      • Jeff Pollard commented  ·   ·  Flag as inappropriate

        Just to confirm, at the time of posting:

        Regardless of Office Sync opt-out settings, all Office 2016 applications are exhibiting one of two opposite behaviours when opening and saving files directly from / to a local instance of a OneDrive folder, depending on whether the file is created inside or outside of that OneDrive folder:

        Steps to reproduce:

        Case 1: Office file is created outside of the local instance of a OneDrive folder and moved into it.
        1.) Create and save an Office document in any local folder outside of the local instance of a OneDrive folder.
        2.) Using Windows Explorer, move the file into the local instance of a OneDrive folder.
        3.) Open the file <- Only the local instance is accessed, not the online instance.
        4.) Save the file <- Only the local instance is accessed, not the online instance.
        This is the expected behaviour: all syncing is performed as a background task by OneDrive.exe, not the Office application.

        Case 2: Office file is created within the local instance of a OneDrive folder.
        1.) Create and save an Office document directly within the local instance of a OneDrive folder.
        2.) Close the file.
        3.) Open the file <- Only the online instance is accessed, not the local instance.
        4.) Save the file <- Only the online instance is accessed, not the local instance.
        This is completely undesired behaviour. Office Sync opt-out settings are being ignored and all syncing is being performed at the time of opening and saving by the Office application, not OneDrive.exe.

      • Anonymous commented  ·   ·  Flag as inappropriate

        We are paying money for OneDrive, so if you have to force such "improvements" on us at least respect the fact that we may not find every feature helpful, and so give us an option to turn this off by default. It's nonsense to say that this can't be done.
        I've got duplicate files happening all the time when it all worked perfectly before the so-called "improvement". Fix it please!

      • Anonymous commented  ·   ·  Flag as inappropriate

        This is 10 steps backward. Remove this as a default option or autosave out as a different file all together so that the original file doesn't get messed with at all. This is a nightmare "feature"

      • Dan commented  ·   ·  Flag as inappropriate

        Onedrive was working perfectly (other than no search within a folder feature) but this update leads to all sorts of sync, duplicate files and upload issues with office 2016. The autosave feature (to the cloud by default) just clashes with the normal onedrive sync process!

      • Steve commented  ·   ·  Flag as inappropriate

        Now they have introduced for MSWord as well as Excel. Please allow us the option to turn off by default. For large files I get frequent syncing problems and updating the last modified date when just viewing destroys my audit trail when looking at the file system. Another own goal from Microsoft, I used to be a great fan but they seem to have lost the plot recently.

      ← Previous 1

      OneDrive: Bugs

      Feedback and Knowledge Base