OneDrive


Feedback by UserVoice

How can we improve OneDrive on Mac?

CPU Usage too high in High Sierra

MacOs 10.13.2
CPU Usage is too high while using one drive.
Please correct!

1,041 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Jürgen Karl shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    136 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • eeWee commented  ·   ·  Flag as inappropriate

        I can confirm that restarting ONEDrive did the trick for me. It went from 100% and above CPU usage even when just sitting on the dock to 0% when not syncing.
        Thanks.

      • Roel commented  ·   ·  Flag as inappropriate

        If I don't restart OneDrive after boot, my battery will only last half a day. With a restart it will last twice as long.

      • Anonymous commented  ·   ·  Flag as inappropriate

        Yes, also happens in Mojave, and I have nothing to sync. It's been normal after i restart Onedrive.

      • Anonymous commented  ·   ·  Flag as inappropriate

        same problem. wonder why my MacBook Pro 13" cpu fan keep spinning & battery dropped fast. Turn OneDrive off solved the problem.Now configured :Uncheck open at login.

      • Josh commented  ·   ·  Flag as inappropriate

        Same issue here. One Drive was using 75-100% and sometimes said over 100% of CPU when not syncing or anything. Adding to Systems Preferences Open at Login and unchecking the OneDrive Open at Login seems to have fixed the problem for me as well.

      • Simon commented  ·   ·  Flag as inappropriate

        Exactly the same problem here, so just adding my voice to the issue, this needs to be addressed ASAP it's been like this for months.

      • Anonymous commented  ·   ·  Flag as inappropriate

        Same here, moved all my files to iCloud now as I am fed of this rubbish program!

      • Nick Byrd commented  ·   ·  Flag as inappropriate

        What fixed it for me:
        - In OneDrive Preferences, turn off (unckeck) "Open at login".
        - In macOS System Preferences > Users & Groups > [Your User] > Login Items, click "+", navigate to "Applications" in the pop-up window, and choose "OneDrive".

        Aside: this procedure fixed the same issue with Dropbox as well.

      • Omar Aleman commented  ·   ·  Flag as inappropriate

        Same problem under Mojave.
        Please fix it, it drains my battery.
        Should we all change to dropbox or gdrive?

      ← Previous 1 3 4 5 6 7

      Feedback and Knowledge Base