Feedback by UserVoice

How can we improve OneDrive on Mac?

OneDrive Files On-Demand for Mac

When will OneDrive Files On-Demand be available on Mac

6,273 votes
Sign in
Sign in with: facebook google
Signed in as (Sign out)
You have left! (?) (thinking…)
Anonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →


Sign in
Sign in with: facebook google
Signed in as (Sign out)
  • Anonymous commented  ·   ·  Flag as inappropriate

    Too bad it works only with APFS filesystem at the moment... Is it even possible to make it support, let say, NTFS through third-party driver (like Paragon NTFS for Mac or similar)?

  • Pierre Trudel commented  ·   ·  Flag as inappropriate

    Update on FOD not working with sharepoint/teams. The problem seem to be with special characters in the name of the site/teams. For example with the Team "Équipe TI" it does not work but il will work with " Projet 365" .

  • KYP commented  ·   ·  Flag as inappropriate

    Still not stable enough.

    I've been waiting for this function for so long because of the limited space of the SSD on my MBP... But I can't wait anymore and I bought a 1TB SSD to upgrade my macbook pro. Problem solved.

  • S. Yilmaz commented  ·   ·  Flag as inappropriate

    Went through all steps and the button for enabling FOD appears, but it just doesn't work after clicking. The File Menu doesn't show the "Free up space" item. Restarted and re-installed multiple times, but couldn't solve the problem. All files get synced to the harddisk as usual. Unfortunately this is stopping our move to Office 365 currently.

  • Mandula József commented  ·   ·  Flag as inappropriate

    Just now i'did setup and tired the fuction and for my suprise it works on SharePoint also. So keep trying!

  • Fred Naud commented  ·   ·  Flag as inappropriate

    Works fine with OneDrive and OneDrive for Business. However, I can't see the FOD options with synced SharePoint folder and doesn't work either with a folder that was shared with me. No option to add a shared with me folder to my OneDrive for business and when I sync a shared with me folder, the FOD options aren't available. This is rendering FOD useless for me.

    Would love to use internally, but FOD not working with SharePoint or Shared with me files is a dealbreaker.

  • Pierre Trudel commented  ·   ·  Flag as inappropriate

    So far it is working with Onedrive and Onedrive for business. I had to disable FOD for my Antivirus because it defeated the purpose. It took me a while to figure this one out. As soon as I freed up space the files would return. The place holder would trigger FOD when the antivirus check them out.

    It does not seem to work for Sharepoint and Teams site. (Do not have the FOD options in the menu and nether see the FOD icons).

    A shame because in an enterprise environnement most of my files are in teams/group sites.

  • Andrei commented  ·   ·  Flag as inappropriate

    I also have a lot of problems on MBP 2018. Besides files syncing randomly and need to relaunch app, the latest thing that happened is that FIles on demand disappeared COMPLETELY from the app. I unlinked PC, re-installed Onedrive, nothing changed.

  • Jay commented  ·   ·  Flag as inappropriate

    I also have the rapid battery drain issue from OneDrive, on a 2018 MacBook Pro. Not a great start.

  • Jay commented  ·   ·  Flag as inappropriate

    This isn't working as expected, constantly have to relaunch Finder on MacBook. Then suddenly OneDrive starts downloading everything onto my disk rendering the FOD feature useless in this build.

    Please fix...

  • Adrian commented  ·   ·  Flag as inappropriate

    OneDrive (AppStore version) was acting up; everytime I tried to click the menu icon it would hang, meaning I did not have any access to the OneDrive menu dropdown and its options.
    So I tried to install this preview on Mojave 10.14.2 beta 18C39b (MBPr 15 Mid 2014), to see if it would fix it - it did not. Sync will occur in the background but if I try to access the menu icon it will hang immediately and the sync process stops.
    As for the current version, on demand files do appear to work, but the client is now using up so much of the CPU just with the sync work that it's tough to test it properly. I've tried removing OneDrive, running the clean up scripts, and this behavior does not change.

  • JorchRock commented  ·   ·  Flag as inappropriate

    YES!! It works!! Except Sharepoint shares... Cannot see them. Negative thing is that I cannot update my working laptop to Mojave :(

  • douglas stewart commented  ·   ·  Flag as inappropriate

    Installed all as instructed and then LR started to download all the files again - not what I was after...

  • Bob commented  ·   ·  Flag as inappropriate

    I am also experiencing this issue reported by Anonymous 10/11. I have also had to uninstall and reinstall the OneDrive app after reboot in order to get finder extensions to show, even though the client shows that Files on Demand is on.

    Number 1 issue is at startup you need to relaunch the Finder for it to show the OneDrive sync icons next to files. I have this scripted in my startup by hand. Seeing high CPU usage when idle sometimes that is killing my battery and I have to quit out of OneDrive.

  • Tseng Wynn commented  ·   ·  Flag as inappropriate


    After update to OneDrive Files On-Demand for Mac.
    Clicking OneDrive icon cause OneDrive freezes(spinning beach ball)
    The only ways to continue using OneDrivw is kill it and relaunch it.

  • Pawel commented  ·   ·  Flag as inappropriate


    we have the same problem in two configurations.
    1. OneDrive app to OneDrive account
    2. OneDrive app to SharePoint Online library
    Files bigger than 50MB are downloaded automatically. When we change flag to "Free up space" after some time files are downloaded again to computer.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Dear Raphael,

    I have exactly the same problem. In my opinion Files On-Demand do not work on Sharepoint connections. On my site the Sharepoint connection did not syncronise at all when Enabling the option (check for updates in Sharepoint ... I didn't see anything). Maybe this is only on my installation. Can you post if you find something out. My mail manuel.stocker at

    Best Manuel

    See my post below.

Feedback and Knowledge Base