OneDrive


Feedback by UserVoice

How can we improve OneDrive on Mac?

remove warning: inode_val: object : invalid bsd flags

Hello,I have found a bug on onedrive for mac. I use Mojave and APFS. I reproduced the issue with the volume encrypted and also without encryption (Filevault). The bug is the following, the folder gives a warning in DiskUtil with the following format:
warning: inode_val: object (oid 0x417de2): invalid bsd_flags (0x10)
I have verified is the onedrive folder using the following command from mac terminal:
find / -inum 4292066

where 4292066 is 417de2 in decimal

427 votes
Vote
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
You have left! (?) (thinking…)
Juan Miguel Duran shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

61 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...
  • Sharad Agrawal commented  ·   ·  Flag as inappropriate

    All - this issue made my Mac very slow and to a point that I had to reinstall macOS after formatting the drive. Disk check revealed tons of bad inod errors before formatting. I have now ditched OneDrive for Mac (for now)

  • Catalambano commented  ·   ·  Flag as inappropriate

    I correct myself: if the "file on request" function is activated and some files are downloaded, opening them, for all these files the warning appears again.

    Therefore the problem is solved only if the "file on request" function is left disabled.

  • Sharad Agrawal commented  ·   ·  Flag as inappropriate

    I noticed that with recent update to MacOS Mojave, this issue is fixed for me and I no longer get the inod bsd flag error when I run disk check.

  • SFH commented  ·   ·  Flag as inappropriate

    Theoretically, what harm is there in leaving OneDrive working with an error like this? I have an SSD (Samsung 860). Does this just mess up your OS installation, or file system, or do actual damage to your drive, or mess up the directory structure or what? I'm sure many people are oblivious to this problem (you don't know its there until you run DU repair).

  • Anonymous commented  ·   ·  Flag as inappropriate

    I get “inode_val: object (oid 0x10afcbb): invalid bsd_flags (ox10)”

    I uninstalled OneDrive, deleted everything related to it, and the OneDrive synced folder and I’m still getting an error.

  • Shiki Suen commented  ·   ·  Flag as inappropriate

    One more thing: This issue, thereotically, shouldn't do significant physical damage to SSD. If there is a such issue, it is likely because of another reason.

  • Shiki Suen commented  ·   ·  Flag as inappropriate

    This is Shiki. Here comes new information forwarded from one of those developers in the OneDrive team:

    Since the introduction of Files-on-Demand, OneDrive utilizes the BSD_flag (0x10) to mark the demanded state of a file. The choice of this BSD flag is made under discussion between Apple and Microsoft. However, the develpers of Disk Utility on the Apple side may know nothing about it yet, and Disk Utility treats this unknown flag as "Reserved" with warnings.

    Note that this flag in (and only in) FreeBSD indicates "uunlink (system no unlink)" which has no relationship with macOS and APFS.

    The radar number is 49155065 (submitted by someone else) and we have to wait for a fix from Apple towards the Disk Utility app in macOS.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Microsoft is aware of the issue and is working with APPLE to deal with this. it will not be an overnight fix but i believe if we all keep reporting the issue and REFUSE to use the APP it will get fixed. I have removed the app from my IMAC latest mojave etc and store my onedrive folder on an external disk with the sync function.

  • sr commented  ·   ·  Flag as inappropriate

    I have deleted the OneDrive app and whatever associated files I could find in the Library folder. I ran DiskUtility and the error persists. Though in my case it's "oid 0xbc272". Anyone know how to fix this? Am I missing something that I should have also deleted? Thanks!

  • Bavo Bostoen commented  ·   ·  Flag as inappropriate

    All my Office 365 clients on Mac that use OneDrive to sync their files have this problem - MS and or Apple should solve this.
    MS should understand that if their OneDrive client software does not work to the same standard as eg DropBox (*), it reflects badly on them and people will extend their criticism to the whole Office 365 suite, whether that is reasonable or not.
    They should invest way more in this, and test everything in-house - just make it work already!

    Regards,
    Bavo

    (*) it certainly is not on par with DropBox, it was even worse in the past but there are still too many problems with OneDrive syncing and also with online document collaboration (which uses OneDrive), no matter of on Mac or Windows, which currently works a lot better in Google product.

  • Juan Miguel Duran commented  ·   ·  Flag as inappropriate

    On my side, in the latest version, 19.012.0121.0009 the issue still present. Could you please check and share your feedback?

  • Anonymous commented  ·   ·  Flag as inappropriate

    It basically killed the SSD from my MacBook Air. Now I am running the OS from an SD card in high Sierra with hfs+ only. And ofc OneDrive cannot be installed on an external drive...

  • Michael Glass commented  ·   ·  Flag as inappropriate

    does anybody know if this bug exists on standalone Word for Mac without entire Office Suite?

  • Anonymous commented  ·   ·  Flag as inappropriate

    My computer is reporting the same issue when running disk utility. It actually seems to be hung at this error. Will disk utility ever complete or should I do a hard reboot. I am hesitant to do a hard reboot out of fear of corrupting my SSD. Appreciate any and all guidance. Thank you.

  • Anonymous commented  ·   ·  Flag as inappropriate

    There are many posts about this on the Microsoft support pages with pleas for Microsoft to fix the issue. However, Microsoft claims it is an Apple issue.

← Previous 1 3 4

Feedback and Knowledge Base